MQTT json without date

Hello everyone,

I subscribed to the mqtt topic as per instructions, using mosquitto_sub.

Correctly I receive a json when the remote device transmits, but the “time” field is missing, everything else is correct.

The gateway I use for the test doesn’t have GPS.

How can I tell the applications server to add the date, because, in the list of devices in the Application, the date and time are shown correctly (Status, last seen at)

Thank you.

One option is to have the gateway add non-GPS time to the payload, if you trust it (using NTP, etc).

Another option is to add times at the application level when you’ve retrieved and processed the message from MQTT.

Hey, thanks.

Is there an application server or gateway bridge configuration to set the current system date?

See fake_rx_time.

Hei, It doesn’t work , set fake_rx_time = true in config file, but nothing.

Same thing as discussed in this topic

Not sure what to tell you on that one. fake_rx_time works perfectly for me with the latest version of the Gateway Bridge across a variety of gateway types (Tektelic, MultiTech, and cloud-based).

I’m using gateway bridge _SNAPSHOT-9ad39b7_linux_arm64 version (around January 25).
Could you share your settings?

Thank you.

Sure, it’s pretty minimal after removing the extra exec functionality we use:



I’ve the same setting, but no date in json. :slightly_frowning_face: