No device-session exists for dev_addr dev_addr=


I’m having a problem on-boarding an existing device onto a new Chirpstack Instance, It’s an OTAA device and I have the DevEUI,JoinEUI and Application key in there and I never seem to get a Join Request.

I have also tried activating using the previous CS app and network session keys with no success.

I can see it in the CS logs and it’s saying:

chirpstack::gateway::backend::mqtt: Message received from gateway region_id="eu868" topic="eu868/gateway/event/up" qos=0 json=true
chirpstack-1  | 2024-02-11T03:45:14.143659Z  INFO up{deduplication_id=1f06e70f-48fa-4c89-9e2a-d60fb279b302}: chirpstack::uplink: Uplink received m_type=UnconfirmedDataUp
chirpstack-1  | 2024-02-11T03:45:14.145020Z  INFO up{deduplication_id=1f06e70f-48fa-4c89-9e2a-d60fb279b302}:data_up: chirpstack::uplink::data: No device-session exists for dev_addr dev_addr=015cabc0

I’ve tried flushing the OTAA device nounces but that hasn’t been successful.

The device is not able to be rebooted but it was all going on my last CS, So not sure what I need to do here???


New ChirpStack imstance doesnt have existing session key of the node yet.

Either importing it to new CS.
Or reboot node.
Or wait a while if the node firmware supports force rejoin after no downlink in a while (hours or days).

1 Like

Thanks @datnus, ok I’m guessing days then as its been missing since the 31st Jan and is on LoRaWAN v1.0.2 and from what I’ve read it can take some time as the device only sends 2 transmissions per day and may take up to 96 uplinks at SF12 to detect that there’s no downlink.

So 96/2 = 48 days, I’m guessing.

The End node can only be read/write to with an IR eye, which I unfortunately don’t have.

Thanks anyway, I thought that maybe the case of incorrect keys. :slightly_smiling_face:

The session keys are stored in Redis.
So may be, there is a way to export the session keys from Redis of old ChirpStack and dump/import to the Redis of new ChirpStack.

1 Like

Thanks @IoTThinks,

I haven’t used Redis tools yet, but will look into it. Are there any repositories that you recommend?

Does the node have a UART interface? If yes, try to attach a serial monitor to it and listen to what it says.

I seldom do it too.
May be a Google search will help.

Thanks @marekpow,
It’s an Axioma w1 meter that uses an IR eye to communicate and I don’t have one unfortunately. So won’t be able to see those logs.

That’s all good @IoTThinks , just thought you maybe using a Redis Tool :slightly_smiling_face:
I’ve looked and have a Redis GUI on my Mac and just need to join it to my CS Resdis.

1 Like