Problem with Sandbox LoRaGo PORT shield conf


I have had the same problem as described here: LoRaGo PORT not working · Issue #89 · chirpstack/chirpstack-gateway-os · GitHub

So basically, it sometimes (but very rarely) would work, but most of the time it wouldn’t work, to a point where I thought I had toasted the shield. It is now working.

Here is what I found:

  • when you choose the shield in the gateway-config menu, the configuration file that is generated at /etc/chirpstack-concentratord/sx1301/concentratord.toml includes the following: |model=“generic_eu868”| and |reset_pin=0|
  • I’ve also noted in gateway-config that the global conf appears empty, not sure whether this is normal or not
  • I’ve looked a bit in the source and tried making it work by changing the model to sandbox_lorago_port_eu868 and lorago_port_eu868 to no avail
  • finally, the only way I ended up have it working was by changing the reset pin manually to 25
  • then I digged a bit in the yocto files and found that: the file located in /meta/recipes-chirpstack/gateway-config seems to have a bug for the sandbox shield.
  • Here we go: in the |do_setup_lorago_port()| function, instead of having something like |1) do_copy_concentratord_config “sx1301” “sandbox_lorago_port_eu868” “” “eu868” “”| it has |1) do_copy_concentratord_config “sx1301” “generic_eu868” “” “eu868” “”|. I’m not too sure this is by design given the functions for the other shields…
  • I’ve tried changing it and rebuilt the image but it didn’t change a thing: the only way was to change the reset pin manually to 25
  • there are very strange situations where it works with generic and pin 0 and survives a gateway reboot. I think it’s mostly just after init and doing very little but I don’t remember what exactly

@brocaar, I hope you can fix what appears to me as a bug in the config files quickly and that it will help others. And thanks A LOT for that: Migrating from Yocto to OpenWrt (preview) - #4 by brocaar. Honestly the current method with docker / yocto is a nightmare. But thanks a whole lot for this generally extremely high quality and efficient software.